Thread: iPad
View Single Post
  #8  
Old 12-14-2014, 06:15 PM
TwoToneshuzz TwoToneshuzz is offline
Senior Member
 
Join Date: Dec 2009
Location: Copenhagen
Posts: 815
Default

Attention this problem is solved by the user!

Hi Jim

I'm getting stuck, my iPad Air with the latest iOS version 8.1.1 and the newest OSCtouch is not behaving as it should.

I'm getting a request for both a send and return port which can't be identical, that means it wants me to setup a send on say 2512 and return on 2513, this seems weird as Numerology only gives an option on one number for each OSC device.. I noticed the first time I'd set it up that it OSCtouch preferences assigned different two numbers automatically in the send and return fields 8000 and 9000.. odd.

Further issues perhaps related to the above
I've got a modulation sequencers step values setup on the touchOSC generic 16 channel mixer, I get nice smooth movement on the first step of the sequence, with the transport stopped, but all the other steps hop from 0 to 1 with no intermediate values.. I've fooled around with the range value for the sequence but to no avail.. Also opened up the mixer in the TouchOSC Editor on the iMac and looked at the values for the faders which go from 0 to 1 as expected.

So that's wehre I'm stopped right now..

There are also toggle buttons on the Mix 16 which I was trying to setup for the selection buttons on the Mod seq, these flash on for a second but don't stay on so they are functioning in a way like momentary switches..

All this makes me think that there's an issue with feedback to the iPad from the ports.. Perhaps TouchOSC is incompatible with the latest version of iOS, or Yosemite or both..

Any help would be appreciated.. in due time of course..

Okay, I'll leave the above question, but I have found the solution, I had muck something up and the TouchOSC app basically locked up, I couldn't find a init command on the app so I deleted it and reloaded it from my purchases on the app store. Now I can see that it uses the 2512 on the outgoing port and has assigned the incoming port to 9000. I'm not wholly sure if this was the cause of the problem as I had mucked around in the Options and Midi bridge pages before I got the advice from Jim, but anyways it's working now so this issue should be marked as solved. TouchOSC seems to do what it needs to do for now, but I'm not sure of how to setup objects, like if I wanted to make a momentary switch or a Radio switch as on the button box in Numerology..

Regards

Wade

Last edited by TwoToneshuzz; 12-14-2014 at 06:59 PM.
Reply With Quote